10 April 2011

MPLS over PPPoE

Overview

This example shows how to set up MPLS network over PPPoE interfaces.

Example network

Image:mpls-pppoe-f.png
As you ca see from illustration above, router R2 is pppoe server and routers R3 and R4 are pppoe clients. Our goal is to run MPLS on this network.
When running MPLS over PPPoE or other tunnels you have to deal with MTU issues. Tunnels add more overhead (in our case PPPoE adds 8 more bytes). To be able to forward 1500 byte IP packet without fragmentation we will need interface that supports

1500 (IP frame)
+ 8 (PPPoE header)
+ 4 (MPLS header)
= 1512bytes
From RouterBoard MTU table you can check if RouterBoard supports 1512 L2MTU.
Lets say that R2 is RB433 and pppoe clients are connected to ether2. From the table you can see that max supported l2MTU for this interface is 1522.
It means that router will be able to forward packets without fragmentations.
Note: Since v5.0 is added proper support for MPLS over PPP. Now by default MPLS is disabled, to enable it go to
/ppp profile menu and set use-mpls=yes



Configuration


R1

/system identity set name=R1

# add loopback interface
/interface bridge 
add name=loopback
/ip address
add address=10.255.255.1/32 interface=loopback
add address=172.16.0.1/30 interface=ether1

#set up ospf
/routing ospf instance
set default redistribute-connected=as-type-1
/routing ospf network
add network=172.16.0.0/30 area=backbone

# set up MPLS/LDP
/mpls interface set 0 mpls-mtu=1512
/mpls ldp
set enabled=yes lsr-id=10.255.255.1 transport-address=10.255.255.1
/mpls ldp interface
add interface=ether1

R2

Note that we have to add static interface for each PPPoE clients, because later on these interfaces will be added to LDP configuration.
/system identity set name=R2

# add loopback interface
/interface bridge 
add name=loopback
/ip address
add address=10.255.255.2/32 interface=loopback
add address=172.16.0.2/30 interface=ether1

# set up pppoe
/interface pppoe-server server 
add interface=ether2 service-name=mpls max-mru=1500 max-mtu=1500

/ppp secret 
add name=mplsR3 service=pppoe remote-address=192.168.0.2 local-address=192.168.0.1
add name=mplsR4 service=pppoe remote-address=192.168.0.3 local-address=192.168.0.1

/interface pppoe-server
add name="mplsR3" user="mplsR3" service="mpls" 
add name="mplsR4" user="mplsR4" service="mpls"

#set up ospf
/routing ospf instance
set default redistribute-connected=as-type-1
/routing ospf network
add network=172.16.0.0/30 area=backbone
add network=192.168.0.2/32 area=backbone
add network=192.168.0.3/32 area=backbone

# set up MPLS/LDP
/mpls interface set 0 mpls-mtu=1512
/mpls ldp
set enabled=yes lsr-id=10.255.255.2 transport-address=10.255.255.2
/mpls ldp interface
add interface=ether1
add interface=mplsR3
add interface=mplsR4



R3

/system identity set name=R3

# add loopback interface
/interface bridge 
add name=loopback
/ip address
add address=10.255.255.3/32 interface=loopback

# set up pppoe
/interface pppoe-client 
add name="mplsR3" max-mtu=1500max-mru=1500 interface=ether2 user="mplsR3" service-name=mpls

#set up ospf
/routing ospf instance
set default redistribute-connected=as-type-1
/routing ospf network
add network=192.168.0.1/32 area=backbone

# set up MPLS/LDP
/mpls interface set 0 mpls-mtu=1512
/mpls ldp
set enabled=yes lsr-id=10.255.255.3 transport-address=10.255.255.3
/mpls ldp interface
add interface=mplsR3

R4

/system identity set name=R4

# add loopback interface
/interface bridge 
add name=loopback
/ip address
add address=10.255.255.4/32 interface=loopback

# set up pppoe
/interface pppoe-client 
add name="mplsR4" max-mtu=1500 max-mru=1500 interface=ether2 user="mplsR4" service-name=mpls

#set up ospf
/routing ospf instance
set default redistribute-connected=as-type-1
/routing ospf network
add network=192.168.0.1/32 area=backbone

# set up MPLS/LDP
/mpls interface set 0 mpls-mtu=1512
/mpls ldp
set enabled=yes lsr-id=10.255.255.4 transport-address=10.255.255.4
/mpls ldp interface
add interface=mplsR4

Testing

At first make sure pppoe clients are connected successfully
[admin@R2] /ppp active> print 
Flags: R - radius 
 #   NAME         SERVICE CALLER-ID         ADDRESS         UPTIME   ENCODING  
 0   mplsR3       pppoe   00:0C:42:21:F1:EA 192.168.0.2     46m                
 1   mplsR4       pppoe   00:0C:42:21:F1:ED 192.168.0.3     46m55s  
Check if OSPF is running properly
[admin@R2] /routing ospf neighbor> print 
 0 router-id=10.255.255.1 address=172.16.0.1 interface=wlan1 priority=1 
   dr-address=172.16.0.2 backup-dr-address=172.16.0.1 state="Full" 
   state-changes=5 ls-retransmits=0 ls-requests=0 db-summaries=0 
   adjacency=5m19s 

 1 router-id=10.255.255.3 address=192.168.0.2 interface=mplsR3 priority=1 
   dr-address=0.0.0.0 backup-dr-address=0.0.0.0 state="Full" state-changes=4 
   ls-retransmits=0 ls-requests=0 db-summaries=0 adjacency=49m33s 

 2 router-id=10.255.255.4 address=192.168.0.3 interface=mplsR4 priority=1 
   dr-address=0.0.0.0 backup-dr-address=0.0.0.0 state="Full" state-changes=4 
   ls-retransmits=0 ls-requests=0 db-summaries=0 adjacency=50m31s 
Ensure LDP is running
[admin@R2] /mpls ldp neighbor> print 
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, 
V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEN
 0 DO   10.255.255.3    10.255.255.2    10.255.255.3:0             no 
 1 DO   10.255.255.4    10.255.255.2    10.255.255.4:0             no 
 2 DO   10.255.255.1    10.255.255.2    10.255.255.1:0             no 
[admin@R2] /mpls forwarding-table> print 
Flags: L - ldp, V - vpls, T - traffic-eng 
 #   IN-LABEL      OUT-LABELS  DESTINATION                    I NEXTHOP        
 0   expl-null    
 1 L 20                        192.168.0.1/32                 m 192.168.0.3    
 2 L 21                        10.255.255.4/32                m 192.168.0.3    
 3 L 22                        10.255.255.3/32                m 192.168.0.2    
 4 L 23                        10.255.255.1/32                w 172.16.0.1     
 5 L 24                        192.168.88.0/24                w 172.16.0.1  
Now we can check if packet switching is working as expected
[admin@R4] /mpls ldp neighbor> /tool traceroute 10.255.255.1 src-address=10.255.255.4
     ADDRESS                                    STATUS
   1     192.168.0.1 13ms 19ms 143ms
                      mpls-label=23
   2    10.255.255.1 38ms 15ms 14ms

VPLS over PPPoE


Overview

This example extends previous setup by connecting two local networks using VPLS tunnel

Example network

Image:mpls-pppoe-vpls.png

RouterBOOT changelog

What's new in 2.33:
  • ) added support for Groove;
  • ) added support for RB751G;
What's new in 2.32:
  • ) fixed beep after failed flashfig on SXT 5HnD;
What's new in 2.31:
  • ) Slight SXT booting speed improvement
  • ) Flashfig initialization improvements (makes sound if Flashfig server not used)
What's new in 2.30:
  • ) fixed RB1000 not to reset configuration all the time (broken in v2.29);
What's new in 2.29:
  • ) fixed rare issue with large nand booting;
  • ) fixed RB800 and RB1100 to turn on user led during boot-up;
  • ) fixed RB711 to turn off user led during boot-up;
What's new in 2.28:
  • ) fixed problem - wireless did not show up on some RB411 units with 18V PoE power supply;
What's new in 2.27:
  • ) memory fix for RB800/RB1000/RB1100;
  • ) fixed problem - sometimes wireless was missing on RB711 after reboot;
  • ) fixed pin-hole reset on RB750G;
What's new in 2.26:
  • ) added RB816 support on RB600;
  • ) fixed router hangup during etherboot if blasted with lots of packets;
  • ) added silent boot;
  • ) fixed Flashfig;
What's new in 2.25:
  • new feature - Flashfig;
  • fixed etherboot on RB493;
  • fixed occasional lockup of kernel image loading on RB400 series;
  • added disable UART feature;
What's new in 2.24:
  • added support for RB816;
What's new in 2.23:
  • added support for RB750G;
  • added support for RB800;
What's new in 2.22:
  • fixed support for RB750;
What's new in 2.21:
  • added support for RB750;
What's new in 2.20:
  • added support for RB450G;
What's new in 2.19:
  • fixed support for MLC NAND chip;
  • fixed memory issue on RB600;
What's new in 2.18:
  • fixed via-rhine disappearing on RB532 and RB564;
  • added support for RB493AH;
What's new in 2.17:
  • added support for MLC NAND chip;
What's new in 2.16:
  • fixed bug - boot from NAND on RB532A could fail (bug introduced in 2.13);
  • fixed bug - etherboot on RB433/RB450 at 10Mbit did not work;
What's new in 2.15:
  • fixed RB333 overheating problem;
  • added support for microSD card on RB433;
What's new in 2.14:
  • fixed nand boot on RB150 (broken in v2.13);
What's new in 2.13:
  • improved memtest;
  • fixed RB600 memory issue;
What's new in 2.12:
  • nand improvement for RB532A;
What's new in 2.11:
  • fixed bug - in one rare case boot from NAND could fail with "data is corrupted" message while data is correctable in reality;
What's new in 2.10:
  • 100ms delay before PCI bus are initialized;
What's new in 2.9:
  • added support for RB192;
What's new in 2.8:
  • fixed CompactFlash resetting router config on RB153 (broken in v2.7);
What's new in 2.7:
  • fixed bug - RouterOS command "/system reset-configuration"
was not resetting RB532 VIA ethernet mac address to default;
  • added support for RB532r5;
What's new in 2.6:
  • fixed CompactFlash reseting router config on RB153;
What's new in 2.4:
  • fixed etherboot on RB100 to work reliably;
What's new in 2.2:
  • fixed repeated initrd image loading;
What's new in 2.1:
  • fixed crash during memory test within RouterBOOT;
What's new in 2.0:
  • added support for RB153;
What's new in 1.13:
  • fixed nand format feature to mark back really bad blocks as bad;
What's new in 1.12:
  • reset-jumper resets bios settings to defaults;
What's new in 1.11:
  • fixed reboot failure on RB500 with new RAM modules;
What's new in 1.10:
  • added workaround for reboot failure on RB500 with new RAM modules;
What's new in 1.9:
  • new boot option - "boot NAND, if fail then Ethernet";
What's new in 1.8:
  • fixed bug - it was possible for RB500 booter to stop working completely;
What's new in 1.7:
  • added nand format feature;
What's new in 1.3:
  • added support for large block NAND devices;
What's new in 1.2:
  • fixed bios entering on key for hyperterminal;
  • routerboard 100 beep before jumping to kernel code;
  • added nand READY/BUSY checking for rb100;
  • improved speed for memory test;

Netinstall

NetInstall Description

NetInstall is a program that runs on Windows computer that allows you to install MikroTiK RouterOS onto a PC or onto a RouterBoard via an Ethernet network.
NetInstall is also used to re-install RouterOS in cases where the the previous install failed, became damaged or access passwords were lost.
  • Your device must support booting from ethernet, and there must be a direct ethernet link from the Netinstall computer to the target device. All RouterBOARDs support PXE network booting, it must be either enabled inside RouterOS "routerboard" menu if RouterOS is operable, or in the bootloader settings. For this you will need a serial cable.
Note: For RouterBOARD devices with no serial port, and no RouterOS access, the reset button can also start PXE booting mode. See your RouterBOARD manual PDF for details.
  • Netinstall can also directly install RouterOS on a disk (USB/CF/IDE) that is connected to the Netinstall Windows machine. After installation just move the disk to the Router machine and boot from it.

Screenshot

File:2009-01-27 1224.jpg
  • for installation over network, don't forget to enable the PXE server, and make sure Netinstall is not blocked by your firewall or antivirus. The connection should be directly from your Windows PC to the Router PC (or RouterBOARD), or at least through a switch/hub.


NetInstall Example

This is a step by step example of how to install RouterOS on a RouterBoard 532 from a typical notebook computer.

Requirements

The Notebook computer must be equiped with the following ports and contain the following files:
  • Ethernet port.
  • Serial port.
  • Serial communications program (such as Hyper Terminal)
  • The .npk RouterOS file(s) (not .zip file) of the RouterOS version that you wish to install onto the Routerboard.
  • The NetInstall program available from the Downloads page at www.mikrotik.com

Connection process

  1. Connect the routerboard to a switch, a hub or directly to the Notebook computer via Ethernet. The notebook computer Ethernet port will need to be configured with a usable IP address and subnet. For example: 10.1.1.10/24
  2. Connect the routerboard to the notebook computer via serial, and establish a serial communication session with the RouterBoard. Serial configuration example in in the Serial console manual
  3. Run the NetInstall program on your notebook computer.
  4. Press the NetInstall "Net Booting" button, enable the Boot Server, and enter a valid, usable IP address (within the same subnet of the IP address of the Notebook) that the NetInstall program will assign to the RouterBoard to enable communication with the Notebook computer. For example: 10.1.1.5/24
  5. Set the RouterBoard BIOS to boot from the Ethernet interface.

Configuring Bootloader

To access Routerboard BIOS configuration: reboot the Routerboard while observing the activity on the Serial Console. You will see the following prompt on the Serial Console “Press any key within 2 seconds to enter setup” indicating that you have a 1 or 2 second window of time when pressing any key will give you access to Routerboard BIOS configuration options.
(press any key when prompted):
You will see the following list of available BIOS Configuration commands. To set up the boot device, press the 'o' key:


What do you want to configure?
  d - boot delay
  k - boot key
  s - serial console
  l - debug level
  o - boot device
  b - beep on boot
  v - vga to serial
  t - ata translation
  p - memory settings
  m - memory test
  u - cpu mode
  f - pci back-off
  r - reset configuration
  g - bios upgrade through serial port
  c - bios license information
  x - exit setup

Next Selection: Press the 'e' key to make the RouterBoard to boot from Ethernet interface:
Select boot device:
* i - IDE
  e - Etherboot
  1 - Etherboot (timeout 15s), IDE
  2 - Etherboot (timeout  1m), IDE
  3 - Etherboot (timeout  5m), IDE
  4 - Etherboot (timeout 30m), IDE
  5 - IDE, try Etherboot first on next boot (15s)
  6 - IDE, try Etherboot first on next boot (1m)
  7 - IDE, try Etherboot first on next boot (5m)
  8 - IDE, try Etherboot first on next boot (30m)

The RouterBoard BIOS will return to the first menu. Press the 'x' key to exit from BIOS. The router will reboot.

Installation

Watch the serial console as the RouterBoard reboots, it will indicate that the RouterBoard is attempting to boot to the NetInstall program. The NetInstall program will give the RouterBoard the IP address you entered at Step 4 (above), and the RouterBoard will be ready for software installation. Now you should see the MAC Address of the RouterBoard appear in the Routers/Drives list of the NetInstall program.
Image:NetinstallStart.png
Click on the desired Router/Drive entry and you will be able to configure various installation parameters associated with that Router/Drive entry.
Image:Nconfig.PNG
For most Re-Installations of RouterOS on RouterBoards you will only need to set the following parameter:
Press the "Browse" button on the NetInstall program screen. Browse to the folder containing the .npk RouterOS file(s) of the RouterOS version that you wish to install onto the Routerboard.
Image:NConfig3.png
When you have finalized the installation parameters, press the "Install" button to install RouterOS.
Image:NetinstallC4.png
When the installation process has finished, press 'Enter' on the console or 'Reboot' button in the NetInstall program.
Image:NetinstallC5.png

Cleanup

1. Reset the BIOS Configuration of the RouterBoard to boot from its own memory.
Image:NetinstallC6.png
2. Reboot the RouterBoard.


Reset RouterOS Password

Netinstall can be used to reset password of RouterOS by erasing all configuration from the router. Uncheck 'Keep Old Configuration' during Netinstall and proceed with standard procedure,

04 April 2011

MikroTik RouterBoard Bootloader upgrade تحديث البوت لودر في بوردة الميكروتك "روتربورد"

This page shows how to upgrade the Bootloader firmware of a RouterBOARD device.
First, check your RouterOS version - does it have the routerboard package installed?
 
 
[admin@MikroTik] > system package print 
Flags: X - disabled 
 #   NAME                           VERSION                           SCHEDULED              
 0   system                         4.0                                                      
 1   routing                        4.0                                                      
 2   hotspot                        4.0                                                      
 3   advanced-tools                 4.0                                                      
 4   mpls                           4.0                                                      
 5   security                       4.0                                                      
 6 X ipv6                           4.0                                                      
 7   ppp                            4.0                                                      
 8   dhcp                           4.0                                                      
 9   routeros-mipsbe                4.0                                                      
10   routerboard                    4.0                                                      
11   wireless                       4.0                                                      
[admin@MikroTik] > 
Then, check your RouterBOARD Bootloader version:


[admin@MikroTik] > system routerboard print 
       routerboard: yes
             model: "750"
     serial-number: "1FC201DD513B"
  current-firmware: "2.18"
  upgrade-firmware: "2.20"
[admin@MikroTik] > 


In this case you see, that there is a newer version of the Bootloader firmware available already inside your current RouterOS version. Note! New Bootloader versions come with the routerboard.npk package when you install and upgrade your router, this is why always make sure you have not forgotten to install this package.

Do the upgrade command now:

[admin@MikroTik] > system routerboard upgrade  

Routerboot will be upgraded.

Second method

If for some reason routerboard.npk package is not, and can not be installed for your RouterOS version, you can upload the Bootloader file directly to the Files folder in RouterOS, and do the command then.

Third method

If there is no IP connectivity with your RouterBOARD, you can also use the Serial Console XMODEM transfer to send the FWF file to the router, while connected via Serial Console. From the Bootloader menu it's possible to upgrade the firmware with this method. This method is the last resort, and should be used only if the first two methods are not available.

03 April 2011

Mikrotik RouterOS v 5.0 Released تم اصدار النسخة 5 من ميكروتك

What's new in 5.0 (2011-Mar-31 11:33):
ما الجديد في الاصدار 5 من ميكروتك
*) route - fixed cause of crashes when handling multipath routes;
*) route - fixed limit on maximum active IPv6 route count,
   was causing issues with more than 2000 active routes;
*) ipsec - added command kill-connections under remote-peers;
*) ipsec - fix responder side phase2 negotiation problem
    which prevented more than one Windows7 host to initiate SA;
*) fixed vrrp - interface was invalid after undoing remove;
*) winbox - added more detailed /interface ethernet stats;
*) winbox - added ability to send e-mail;
*) winbox - added missing 'set-metric' parameter
   in 'Routing/Prefix List';
*) wireless - 802.11 dynamic distance fix;
*) fixed problem - packages could not be uninstalled if disk was full;
*) fixed problem - some of the RouterBOARDS did not reboot properly sometimes;
*) fixed problem - VLANs on bridge interface did not work;
*) ssh - client supports public key authentication;

What's new in 5.0rc11 (2011-Mar-04 14:29):

*) led trigger - changed blinking for modem signal and interface monitoring;
*) ppp - added ability to specify data-channel for ppp server interfaces;
*) ipsec - added more Diffie-Hellman groups;
*) console - fixed a memory leak;
*) console - don't recreate default '/system console' entry for the serial
    port if it is removed;
*) netinstall - fixed CD-ROM & usb install;
*) wireless nv2 - fixed RB532 freeze;
*) wireless - fixed station-bridge mode;
*) wireless - added station-bridge support for 802.11 and nstreme;
*) gps - show higher precision coordinates;
*) snmp - added OIDs for kvm and metarouter;
*) usermanager - works again and to make user profile active after signup,
                please recreate relevant user profiles;

What's new in 5.0rc10 (2011-Feb-17 14:06):

*) routing - fixed ipv6 connected routes,
    IPv6 connected routes disappeared after interface restart;
*) routing - fixed high CPU usage when adding BGP ipv6 routes;
*) winbox - fixed opening terminal window to KVM instance;
*) winbox - fixed connect button in wireless scan;
*) winbox - fixed make-binding in hotspot hosts;
*) ipsec - fix possible crash when ipv6 is enabled;
*) snmp - add usb power reset (see updated MIB);

What's new in 5.0rc9 (2011-Feb-09 13:57):

*) wireless - fixed disconnect problem on long distance
   802.11 40MHz links;
*) wireless nv2 - fixed station mode that broke when station-bridge
   was introduced
*) wireless - more improvements for 11n compatibility;
*) routing - fixed problem with best route selection, sometimes inferior route
    could get selected as the active, problem was introduced in 5.0rc8;
*) kvm - fix guest starting;

What's new in 5.0rc8 (2011-Feb-01 14:03):

*) added led trigger - change leds on different events;
*) snmp - restored access to routing tables;
*) snmp - fixed memory leak for OID 1.3.6.1.2.1.25.2;
*) ipsec - added ipv6 support;
*) removed broadcast setting from ip address;
*) radv - fixed problem when wrong link local address was used
   to send advertisements on bridge interface;
*) ppp - make IPv6 work again (introduced in v5.0rc7);
*) ppp - fixed problem when user re-authenticated and traffic accounting
   included data from previous session;
*) fixed traffic-flow on x86-smp (could stop sending flows);
*) improved usb modem mode switching;
*) kvm - fixed problem when sometimes virtualization detection fails;
*) routing - route with recursive gateway sometimes was not selected as
    active, if another inferior route with directly reachable gateway
    was present;
*) bgp - removed "interface" property from bgp peer configuration, now
    ipv6 link local remote address must be specified using the
    "address%interface" notation;
*) added extended ethernet statistics (/interface ethernet print stats) for RB800,RB1000,RB1100 and RB7xx with AR7241 or newer cpu;
*) wireless - improved 11n compatibility;
*) wireless nv2 - added support for station-bridge mode;
*) wireless nv2 - added area support;
*) wireless - added ability to set registration-table comment using RADIUS
   attribute;
*) implemented usb power-reset command on RB SXT 5HnD;

What's new in 5.0rc7 (2010-Dec-29 10:39):

*) fixed hotspot;
*) tftp - fixed problem when nobody could
   connect if no ip-address were provided;
*) winbox - fixed mac ping from neighbor list;
*) fixed simple queues on little endian cpus;
*) fixed simple queues without provided dst-address;
*) fixed problem - could not update license for
   old style 7 digit software-id's;
*) fixed winbox - IPv6 route could not be added;
*) ssh - allow bigger packets (fixes some disconnecting problems);
*) added support for RDC R6040 Ethernet controller;

What's new in 5.0rc6 (2010-Dec-23 13:33):

*) ntp server now requires a broadcast address for broadcast mode to work
   it should be specified under broadcast-addresses (X.X.X.255),
   255.255.255.255 is not going to work;
*) ssh - fixed showing forwarding settings,
   check your setting after upgrade!
*) allow to specify multiple networks (including IPv6)
   in user's allowed-from list;
*) added support for Safe Mode to WinBox;
*) allow to specify non acceptable groups for RADIUS console logins;
*) handle correctly IPv6 address on bridged or switched interfaces;
*) added IPv6 connection list;
*) added IPV6 support to graphing;
*) added IPv6 support to SNTP client;
*) added IPv6 support to NTP client & server;
*) added IPv6 support to RADIUS client;
*) added IPv6 support to snmp;
*) added IPv6 support to tftp server, also changed logging levels;
*) added IPv6 support to ssh client;
*) added IPv6 support to watchdog;
*) added IPv6 support for /tool e-mail;
*) added IPv6 support to log remote target;
*) added IPv6 support to API;
*) added IPv6 support to winbox;
*) added IPv6 support to ftpd;
*) added IPv6 support to netwatch;
*) added IPv6 support for /queue simple;
*) added IPv6 support for /tool bandwidth-test;
*) added IPv6 support for /tool torch;
*) added IPv6 support for /interface vrrp (version 3);
*) added IP/IPv6 over ipv6 tunnel interface (/interface ipipv6);
*) added Ethernet over IPv6 tunnel interface (/interface eoipv6);
*) snmp - added ipv6AddrTable from IPV6-MIB;
*) wireless nv2 - fixed station-wds mode multicast problem;
*) wireless nv2 - fixed occasional encrypted link stalls;

What's new in 5.0rc5 (2010-Dec-01 07:47):

*) logging - added email-starttls option for email target;
*) pcq - added burst settings, like in "/queue tree" and "/queue simple";
*) pcq - can specify address masks for pcq;
*) pcq - added ipv6 support;
*) wireless - fixed WPA;
*) radius - fixed encryption key decoding for wireless EAP & PPPs;
*) winbox - make keyboard work right away after main window is activated;
*) snmp - fix BER encoding for negative INTEGER values;

What's new in 5.0rc4 (2010-Nov-22 16:58):

*) radius - fixed Disconnect and CoA response signature generation;
*) winbox - make double click work in text fields again;
*) winbox - allow to drag windows outside of main one to the left;
*) winbox - make some settings look more consistent;
*) winbox - allot to specify IPv6 address in routing filter prefix;
*) winbox - make possible to open IPv6 routes without crashing;
*) winbox - improved item reordering in long lists;
*) winbox - improved SNMP configuration support;
*) winbox - added support for KVM configuration;
*) winbox - added support for Traffic Engineering configuration;
*) ovpn - make ovpn client work with OpenVPN v2.1.3;
*) lcd - support Crystalfontz 631,633
    also support for Crystalfontz lcd contrast setting is added;
*) console - fixed missing return value of the ping command when executed
    from a scheduler entry;
*) console - 'ping' command with specified value of 'interface' always forced
    "arp-ping=yes", fixed;
*) routing - fixed problem with 'check-gateway' status update that could get
    triggered when multiple routes with different values of 'target-scope'
    and 'check-gateway' referenced the same gateway IP address;
*) store - allow to use external disks;
*) modem firmware directory can be specified in /port firmware
    Gobi users should change this setting or directory name;
*) ups - support USB UPS on RB4xx as well;
*) snmp - fix BER encoding for some INTEGER based values;
*) snmp - provide proxy stats using SQUID-MIB;
*) snmp - provide ups info using UPS-MIB;
*) snmp - provide external storage information;
*) wireless nv2 - add missing statistics fields;
*) wireless - add per-chain signal strength fields;
*) added hotspot html variable "host-ip";
*) fixed pcq queue type;
*) fixed leds on RB750;
*) added hotspot html variable "host-ip";
*) wireless nv2 - fixed station-wds mode multicast problem;
*) wireless nv2 - fixed occasional encrypted link stalls;

What's new in 5.0rc3 (2010-Oct-29 09:02):

*) lcd - support Crystalfontz 635
*) wireless nv2 - fix stalls on encrypted 11n links using high rates;
*) wireless nv2 - fix encryption related kernel crash;
*) sstp - fixed memory leak;
*) fixed problem - bad boot/kernel crc was reported on powerpc boards
   when in fact it was good;

What's new in 5.0rc2 (2010-Oct-27 16:20):

*) wireless nv2 - encryption support;
*) tool fetch - support ftp STOR;
*) ospf - fixed crash when working with external LSA that contain
    forwarding addess;
*) ipsec - supports NAT-T drafts;
*) ipsec - added debug logging, to maintain same log verbosity as before with
    'ipsec' topic now use topics 'ipsec,debug,!packet';
*) ipsec - make it work with EoIP, GRE, PPTP and L2TP;
*) support for Atheros AR9271 wireless chip;
*) added support for more Intel 82575/82576 PCI-Express Gigabit Ethernet cards;
*) added support for idle detection on RB1xx/RB5xx in /tool profile;
*) fixed Wireless manual tx power configuration for 11n rates in WinBox;
*) fixed torch;

What's new in 5.0rc1 (2010-Sep-17 13:58):

*) wireless nv2 - add WDS support;
*) added ability to monitor cpu usage by task (/tool profile);
*) added support for RPS (Receive Packet Steering) on multicore systems;
*) added cisco compatible gre tunnels;
*) fix simple queues on multicore (fixes intel 82576 crash/reboot);
*) fixed sstp memory leak;
*) winbox - fixed ability to configure RB1100 switches;
*) ssh - fix possible crashing;
*) snmp - fix GET request processing;
*) ipsec - added ability to specify ID_USER_FQDN peer identity;
*) ipsec - encypt last IKE phase 1 packet when in aggresive mode as initiator;
*) wireless nv2 - added nv2-cell-radius parameter to specify distance
     in km to farthest client on AP;
*) wireless nv2 - fix transmit stall issue for non-11n chips;
*) wireless - fix x86 nstreme multiprocessor hang;
*) made user manager web interface work again;
*) updated drivers and kernel (to linux-2.6.35);

What's new in 5.0beta6 (2010-Aug-10 13:22):

*) sstp - fixed memory leak;
*) wireless - changed band setting and added channel-width setting
*) wireless - support for 11n rates in 5&10mhz channels
*) wireless nv2 - fixed multiple problems including occasional tx stall;
*) made gps accessible through SNMP;
*) snmp - added GETBULK support, no more table caching - solves problems
            with huge tables, routing tables currently are not available;
*) ssh - fixed public key authentication in case
        when client is not verifying if server will accept the key;
*) fixed problem - MetaROUTER did not work on RB800, RB1000 & RB1100;

*) user manager is not working - will be fixed in next version;
*) intel 82576 (uncommon expensive chip) crash/reboot to be fixed in
   next release;

What's new in 5.0beta5 (2010-Jul-23 14:50):

*) email - supports multiple CCs
*) fix 5&10MHz channel support for 11n cards;
*) ssh - fix ssh client crash;
*) ssh - password authentication is disabled for users with public keys;
*) ping - fixed ping packet-loss calculation;

What's new in 5.0beta4 (2010-Jun-28 16:17):

*) console - /ping command again returns number of ping responses received,
    didn't work in 5.0beta3;
*) added ability to monitor each cpu core usage;
*) added support for SATA,SCSI & USB CD-ROMs in CD installer;
*) fixed problem - IRQ balancer did not use correct CPU core
   on non auto MSI irqs after reboot;
*) fixed memory leak;
*) route - new property 'vrf-interface' (for static and dhcp routes),
    automatically updates 'routing-mark' of the route to keep it in the same
    VRF as the specified interface;

What's new in 5.0beta3 (2010-Jun-17 13:46):

*) hotspot - drop hotspot specific tcp connections from non-hotspot clients
   already at firewall;
*) lcd - added support for AX89063
*) console - output of '/ping' and '/tool traceroute' commands is more
    in line with the rest of the console commands;
*) api - '/ping' and '/tool traceroute' commands are fully functional;
*) console - added 'server' and 'server-port' arguments to '/resolve' command;
*) lcd - show free/total memory in units of million bytes (MB);
*) lcd - added page that shows system identity;
*) sstp - made it work with Windows 7;
*) sstp server - client reconnects did not work;
*) winbox - implemented proper maximize support for inner windows;
*) fix 5&10MHz channel support for 11n cards;
*) added IRQ balancer;
*) enabled PCI MSI on i386 multicore setups;

What's new in 5.0beta2 (2010-Apr-30 11:24):

*) added wireless distance setting, removed ack-timeout;
*) improved 802.11 operation for outdoor distances;
*) fixed sstp on x86;
*) console - removed 'delay' argument from '/system scheduler add' command;
*) console - remove 'comment=""' values from export;
*) console - updated '/system script job':
    - also show active login sessions here;
    - new read-only property 'type' with values "command", "login"
        or "api-login" for running commands and either kind of login sessions;
    - new optional read-only property 'parent' with id of the job that
        has spawned this one;
*) console - changed "started" property of '/system script job' to use
    local time;
*) console - new property 'type' in '/system script job'
*) console - added '/port remote-access export' command;
*) console - fixed bug that caused "cannot set ..." error when using
    some properties in 'find' commands;
*) show old software id in export file header;
*) api - can supply password to '/system/upgrade/upgrade-package-source/add';
*) api - 'print' command was not showing values of some properties
    such as 'servers' in "/ip/dns";
*) api - fixed api login sessions not dissapearing from '/user active' after
    termination;
*) '/user active' now lists type of api connections as 'api';
*) added support for hardware watchdog on RB1000 & RB800;
*) added support for ASIX AX88xxx based USB Ethernet Adapters on RB4xx;
*) fixed problem - ipv6 traffic was not bridged if ipv6 package was not enabled;
*) fixed getting interface stats in dude;
*) fixed metarouter stability problem on RB400s & RB750s;
*) fixed metarouter - it didn't work on RB1000 with 2Gb;
*) fixed metarouter - it locked up on RB800;
*) fixed problem - SFQ queues did not work on interfaces (wireless) if none
   of simple or tree queues were added;
*) fixed RB800 temperature;
*) fixed problem - WinBox crashed while opening VAP interface;
*) dhcp server - fixed possible inactive dhcp server in case of many
   dhcp leases with address-pool enabled;
*) dhcp server - show non-printable option 82 agent-circuit-id and
   agent-remote-id values in hexadecimal notation
   (in the same way as client-id is shown);

What's new in 5.0beta1 (2010-Mar-31 09:17):

*) updated drivers and kernel (to linux-2.6.32.5);
*) ssh is now completely rewritten (supports connection forwarding, only DSA keys);
*) added support for SSTP protocol (PPP over TLS);
*) added support for multiple Intel Ethernet cards;
*) added support for IPv6 over PPP
   (enabled by default if ipv6 package is installed),
   link-local addresses are assigned, and server can issue IPv6 global prefixes
   to clients per ppp secret or RADIUS reply (Framed-IPv6-Prefix);
*) added proper support for MPLS over PPP (by default it is now disabled);
*) fixed RB800 temperature;
*) silentboot feature updated;
*) WinBox - any file dropped on WinBox will be uploaded to router;
*) multicast - fixed possible crash during PIM startup;
*) report platform name in "/sysrem resource";
*) fixed problem - vlans were not working on RB750 ether1;
*) fixed mac address handling on RB750, some specific arp requests did not work;
*) more than two dns servers allowed in /ip dns;
*) sniffer and torch could process packet from other interfaces;
*) ospf - fixed DR and BDR election;
*) ospf - changed "/routing ospf route" to show type 2 metric instead of
    internal metric for type 2 external routes;
*) added IPv6 support to trafflow (v9 only);
*) rewritten user-manager (formerly known as userman-test);
*) dns cache rotates order of records in reply messages

What's new in 4.6:

*) only accept dotted decimal notation for IP addresses. Use of numbers
    with leading zero, numbers larger than 255 and non-decimal numbers
    is not accepted (but still can omit third or second and third numbers,
    if they are zero);
*) email - user must enable tls explicitly
*) remove limit on number of multicast enabled interfaces, maximum was 32;
*) dhcp server - show last-seen time for leases;
*) fixed - when closing winbox terminal window with active serial-terminal
    console command, serial port sometimes was left in acquired state;

What's new in 4.5:

*) ipsec - added blowfish, twofish, and camellia encryption algorithms;
*) fixed static route removing;
*) fixed DHCP client compatibility with some DHCP servers;
*) added static multi-cast route support;
*) fixed temperature monitor on RB800 and RB450G;
*) user manager - payment bug fix - now able to buy 
   credits without extend price specified;

What's new in 4.4:

*) snmp - fixed snmp version three;
*) snmp - fixed vlan interface speed;
*) hotspot - fixed radius variables in hotspot html pages;
*) removed support for xen;
*) routing - added support for BFD protocol;
*) fixed problem - MetaROUTER sometimes froze on RB4xx;
*) fixed OSPFv3 on bridge interfaces;

What's new in 4.3:

*) kvm - vnc support, booting from cdrom image
*) API - fixed possible crash when running concurrent commands;
*) console - fixed logging commands: 'warning', 'error' and 'debug' were
    all using 'info' topic;
*) bgp - added routing-table configuration option for instances;
*) bgp - added 'as-override' and 'passive' configuration options for peers;
*) bgp - added support for Site of Origin extended communities;
*) bgp - fixed some network issues;
*) ospf - fixed problem: when last neighbor on multi-access interface disappeared,
   incorrect RouterLSA was generated on designated router;
*) metarouter - allow to specify metarouter's memory size when importing image;
*) firewall - added 'routing-table' matcher;
*) fixed problem - e1000 driver did not work in virtual machines;

What's new in 4.2:

*) fixed problem - RB450G ethernet did not work if one of the ports was disabled;
*) fixed ethernet of RB433 with switch chip IP175D;
*) fixed route attribute problem;
*) fixed route next-hops falling under multiple connected routes;

What's new in 4.1:

*) fixed problem - RB750 (clocked at 300MHz) Ethernet did not work;
*) fixed problem - routes on some interfaces (like VLAN) were not activated;
*) ppp, gps, sms, serial terminal - allow use of different channels
    on same port across multiple programs simultaneous
*) dhcp server - added support for dynamic address-list entries;
*) hotspot - added support for dynamic address-list entries;
*) hotspot - fixed redirect after login in case if client gets new IP address
   (problem introduced in 3.28);

What's new in 4.0:

*) IT87XX hardware monitoring sensor support;
*) kvm allows to choose emulated nic model;
*) hotspot - fixed redirect after login in case if client gets new IP address
   (problem introduced in 3.28);
*) hotspot - fixed redirect after login in case if client gets new IP address;
*) console - commands like 'monitor', 'torch' and others that periodically
    refresh information sometimes failed to work when started from
    the scheduler;
*) console - scheduled scripts no longer require 'test' policy to run;
*) console - fix issues with scripts that contain lines with trailing spaces;
*) console - add back compatibility with old scripts that use space instead
    of '=' to separate argument name and value;
*) console - following fixes:
    - accept item numbers when prompted by command to specify item;
    - argument names without '=' were matched even when expecting unnamed
        value; this broke code such as:
           :foreach i in=1,2,3 do {}
       here 'i' was matched as argument name "in";
    - 'tab' key did not automatically append '=' after complete argument
        names;    

What's new in 4.0rc1:

*) console - removed support for Lua (will be reintroduced later);
*) incorporated all the bug fixes since v3.30;
*) port remote-access - added 'log-file' property. If value is a non-empty
    string, then all data that is read from the port is appended to a file
    with that name, regardless of the active remote connection;
*) console - removed '/user' from the output of top level '/export' command,
    still can be exported by '/user export';

What's new in 4.0beta4:

*) routing - changed BGP network and default-originate behavior;
*) web proxy - allow to edit error page;
*) console - terminal window size change now does not trigger full terminal
   reset;
*) mesh protocol - improved loop prevention (becomes incompatible with earlier versions);

*) incorporated all the bug fixes since v3.27;

What's new in 4.0beta3:

*) added support for 802.11n atheros based wireless cards;
*) added ability to run other OSs in MetaROUTERs;
*) console: Lua scripting language. http://wiki.mikrotik.com/wiki/Lua
*) console: added nstreme-dual OIDs;
*) incorporated all the bug fixes since v3.23;

What's new in 4.0beta2:

*) console: added 'without-paging' argument to 'monitor' commands;
*) console: now 'without-paging' and 'interval' arguments in of 'print'
    commands work together. Printing can be stopped by pressing 'q' or
    ctrl-c, any other key triggers printing;
*) incorporated all the bug fixes since v3.22;
*) fixed TFTP server logging;
*) fixed problem - "/system upgrade" did not show proper package
   architecture and was unable to fetch new packages;

What's new in 4.0beta1:

*) added support for MetaROUTERs;
*) all test packages are regular ones;
*) console - can mix named and unnamed arguments, can use names for unnamed
     argument values. For example all of the following commands are
     accepted now:
       /ping 10.11.12.13 count=4
       /ping address=10.11.12.13 count=4
       /ping count=4 10.11.12.13

GoDaddy coupon code , offers & promotions

click the discount you want and it will be applied to your order automaticlly
عروض وتخفيضات جودادي علي الدومينات (النطاقات) والاستضافة
اضغط علي العرض الذي تريده وسيتم تحويلك الي صفحة جودادي وستستفيد بالعرض اوتوماتيكيا
25% off New Customer Orders at GoDaddy!
25% off New Customer Orders at GoDaddy!
$7.49 .COM Domains at Go Daddy
$7.49 .COM Domains at Go Daddy
$7.49 .COM Domains at Go Daddy
$7.49 .COM Domain Sale at GoDaddy.com
Free Domain Privacy at Go Daddy!
Free Domain Privacy at Go Daddy!


$7.49 .COM for Wedding Websites at Go Daddy

$7.49 .COM for Wedding Websites at Go Daddy
Proud to Sponsor Mark Marting- $7.49 .COM Domains
$7.49 .COM for Wedding Websites at Go Daddy
$1.99 Website Hosting- Go Daddy Proud Sponsor of Danica Patrick
$1.99 Website Hosting- Go Daddy Proud Sponsor of Danica Patrick
$1.99 Website Hosting- Go Daddy Proud Sponsor of Danica Patrick
Get Online Fast- $7.49 .COM Domains at Go Daddy
$7.49 .COM Domains at Go Daddy
Get Online Fast- $7.49 .COM Domains at Go Daddy
Faster Web Hosting Close to Home- EU Data Center
Go Daddy Web Hosting from Asia Pacific Data Center
$1.99 Web Hosting at GoDaddy.com.com
$7.49 .COM Domain Sale at GoDaddy.com
Getting Online Shouldn't be Tough- $7.49 .COM Domains at Go Daddy
Getting Online Shouldn't be Tough- $7.49 .COM Domains at Go Daddy
$12.99 SSL Certificates at Go Daddy
$12.99 SSL Certificates at Go Daddy
$10.99 .CO Domains from GoDaddy.com
GoDaddy.com
Domain Auctions at GoDaddy.com
Build your own website at GoDaddy.com
$10.99 .CO Domains from GoDaddy.com
$12.99 SSL Certificates at GoDaddy.com
$10.99 .CO Domains from GoDaddy.com
$7.49 .COM Domains from GoDaddy.com
Go Daddy Website Hosting- Cloud Server
GoDaddy Hosting and WordPress
Go Daddy Website Hosting
Go Daddy Website Hosting
$10.99 .CO Domains from GoDaddy.com
$10.99 .CO Domains from GoDaddy.com
GoDaddy.com
GoDaddy.com

GoDaddy.com
$10.99 .CO Domains from GoDaddy.com